[time-nuts] Efratom/Datum GPSDO GPS-FC

Bob Camp kb8tq at n1k.org
Mon Jun 1 06:52:25 EDT 2015


The biggest issue I see is that the module thinks it’s in the vicinity of New York City. 
Since it’s in position hold mode, it’s not going to lock up at your location. 

Next step is to watch the module dialog as it boots up. See what the CPU
on the board is doing to the module at power on. Either the location is
stored in the module (which I doubt) or it’s stored in the CPU. If the 
location is in the module, you can pull it and re-initialize it. If the location
is in the CPU that’s not going to help. 

Since the Oncore module seems to be working ok, I would not replace it.


> On May 31, 2015, at 10:11 PM, Vlad <time at patoka.org> wrote:
> Bob,
> Many thanks indeed for taking the time for your answers !
> I load TAC32 to decode the messages.
> Here is what I got:
> http://www.patoka.ca/OCXO/Moto1.JPG
> http://www.patoka.ca/OCXO/Moto2.JPG
> Looks like I have no "visible" satellites. However its shows me four Tracked sats.
> The FW for the device is pretty old. I am not sure if its a good idea to replace that GPS Oncore module with module which not that old and has newer microcode.
> Regards,
> Vlad
> On 2015-05-31 20:55, Bob Camp wrote:
>> Hi
>> So now you need to feed the data stream into any of the free programs
>> that will display what’s going on with that data stream. Since
>> it is a well known protocol, that’s a lot easier than trying to
>> demodulate the strings by hand.
>> Bob
>>> On May 31, 2015, at 8:45 PM, Vlad <time at patoka.org> wrote:
>>> Its definitely VC TCXO. For the tests, I disconnected GPS-FC "embedded" antenna and connect it to my GPS distribution amplifier. In this case I could have GPS signal indoor. Its not perfect. But should be enough for troubleshooting.
>>> I soldered TTL Serail sniffer to GPS-FC and I got following:
>>> (Rx)@@At 00
>>> (Rx)@@At 00
>>> (Rx)@@Aw 00
>>> (Rx)@@Ea 060107DF0024190008E0BA0000000000000000000000000000000000000000000001000009000000190000001B000000130000001600000014000000020000000500000008
>>> (Rx)@@En 0101000A010000010000000000000001010202000021092FAF080019800000001B00000000130000000D16FFFFFFFF1400000039020000006F0500000000
>>> (Rx)@@Ea 060107DF00241A0009BC930000000000000000000000000000000000000000000001000009000000190000001B000000130000001600000014000000020000000500000008
>>> (Rx)@@En 0101000A010000010000000000000001010202000020112FAF08001F8000000007000000000C0000FACD0FFFFFFFFF1800381998060022189B0400000000
>>> (Rx)@@Ea 060107DF001F2F0002C27800000000000000000000000000000000000000000000010001110000001F000000070000000C0825A20F00000018000020060000200400000008
>>> (Rx)@@En 0101000A0100000100000000000000010102020000FD112FAF08001F8000000007000000000C0001E5820FFFFFFFFF1800381998060022189B0400000000
>>> (Rx)@@Ea 060107DF001F300003AD2C00000000000000000000000000000000000000000000010001110000001F000000070000000C0826A20F00000018000020060000200400000008
>>> Which, I think, looks like Motorola protocol. And that means the GPS module is responsive.
>>> Regards,
>>> Vlad
>>> On 2015-05-31 16:47, Bob Camp wrote:
>>>> Hi
>>>> If you look at the pictures you can see the oscillator they are using
>>>> for the 10 MHz. At least as far as I can see
>>>> it’s markings look like those of a VC TCXO. If you mount the device
>>>> outdoors (as you must to get it to work) there
>>>> will be a lot of temperature swings. In if the little oscillator *is*
>>>> an OCXO, it’s not a fancy one. Between the
>>>> simple oscillator and the outdoor location, you are unlikely to get
>>>> very good performance out of the unit.
>>>> The Oncore in this device has many of the same issues as ones we have
>>>> discussed in other GPSDO’s. The
>>>> design of the one in your gizmo is now approaching 20 years old. The
>>>> interface strings are well documented
>>>> and you should be able to tap into the module’s i/o stream to see
>>>> what’s going on. I would recommend tacking
>>>> a TTL to USB converter onto it and letting a terminal program show you
>>>> what is happening.
>>>> Bob
>>>>> On May 31, 2015, at 11:58 AM, Vlad <time at patoka.org> wrote:
>>>>> Hello,
>>>>> Some time ago, I got Efratom/Datum GPS-FC item. The apparatus itself looks like good quality weather-proof aluminium case with embedded GPS antenna. It has only one connector. That connector is using to supply the power to the unit and as well to get 10Mhz signal from it.
>>>>> Here is the sticker inside of the devices:
>>>>> http://www.patoka.ca/OCXO/GPS-FC-LBL.JPG
>>>>> I tried to play with this device, however all my attempts to get 10 Mhz from it has failed.
>>>>> Here is how its looks inside:
>>>>> http://www.patoka.ca/OCXO/GPS-FC-PCB.JPG
>>>>> AFAIK, there is Motorola Oncore GPS. I checked the 1PPS signal from that module and its looks good - I see the 1PPS on my scope.
>>>>> Also I did check on TP4 on PCB. Looks like its an output from 10Mhz VTCXO. And I see the sine on the scope.
>>>>> I tried to contact Microesemi to obtain some service manual or even schematic for this unit, but unfortunately its not an option. Microsemi sent me only this manual:
>>>>> http://www.patoka.ca/OCXO/GPS-FC-Manual.pdf
>>>>> Its appeared this units out of support for long period of time. So, I would ask if anybody knows anythings about it ? Especially I would be interested about what to measure/expect on control points on PCB. I still hope its repairable. Thanks in advance !
>>>>> --
>>>>> WBW,
>>>>> V.P.
>>>>> _______________________________________________
>>>>> time-nuts mailing list -- time-nuts at febo.com
>>>>> To unsubscribe, go to https://www.febo.com/cgi-bin/mailman/listinfo/time-nuts
>>>>> and follow the instructions there.
>>> --
>>> WBW,
>>> V.P.
> -- 
> WBW,
> V.P.

More information about the time-nuts mailing list